Startseite > 2010, SharePoint > Neuer Server in Serverfarm –> Serverseitige Abhängigkeiten fehlen

Neuer Server in Serverfarm –> Serverseitige Abhängigkeiten fehlen


Nach dem ich einen neuen SharePoint Server in eine bestehende SharePoint Farm eingebunden habe und dabei der Konfiguration Wizard verwendet wurde, habe ich die folgenden Fehlermeldungen im Eventlog erhalten.

ServerSeitigeAbh-2erFarmServer

In dieser Fehlermeldung wird auf mehrere Features und Webpartklassen verwiesen wie z.B.:
– Microsoft.Office.Server.Search.WebControls.SearchTopologyView
– Microsoft.Office.Server.Search.WebControls.AdvancedSearchBox
– Microsoft.Office.Server.Search.WebControls.QuerySuggestionsWebPart
…….

Diese Fehlermeldung wird in den Eventlogs des neue SharePoint Servers der Farm angezeigt, zusätzlich ist die Fehlermeldung auch noch in der SharePoint-Integritätsanalyse der Zentraladministration sichtbar.

Lösung

Ich habe dann diesen Server aus der Farm wieder entfernt, danach habe ich die Analyse der Fehlermeldung in der Zentraladministration erneut gestartet und die Fehlermeldung war nicht mehr vorhanden.

Den Server habe ich dann mit Powershell in die Serverfarm gebracht, folgende Befehle wurden dafür verwendet.

Verbinden des Servers mit der ConfigDatenbank
Connect-SPConfigurationDatabase -DatabaseServer "SQLServer” -DatabaseName “SharePointConfig” -Passphrase (ConvertTo-SecureString “Passwort” –AsPlainText –Force)

Dateiauflistung der Hilfe installieren
Install-SPHelpCollection –All

Sicherheitsresource initialisieren
Initialize-SPResourceSecurity

Grundlegendene Dienste installieren
Install-SPService

Alle schon vorhandenen Features installieren
Install-SPFeature –AllExistingFeatures

Schon vorhandenen Anwendungsinhalt installieren
Install-SPApplicationContent

Sollten danach noch Fehlermeldungen vorhanden sein, das z.B. der Timerdienst nicht ordnungsgemäß funktioniert. Muss der Server einmal durch gestartet werden.

Hinweis: Leider konnte ich noch nicht überprüfen ob man diese Fehlermeldungen auch  beseitigen kann, wenn der Server mit den Konfigurationswizard in die Farm eingebunden wird und danach die PowerShell Befehle ausgeführt werden. Dabei brauch natürlich nicht der Befehl zum verbinden mit der KonfigDB verwendet werden.

Wenn jemand Erfahrungen dazu gemacht hat, wäre es super wenn er dieses vielleicht als Kommentar erwähnt.

Gruß

Mario

Kategorien:2010, SharePoint
  1. Es gibt noch keine Kommentare.
  1. No trackbacks yet.

Schreibe einen Kommentar

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s

%d Bloggern gefällt das: