Startseite > 2010, SharePoint > Kein Zugriff auf eine lokale Webseite / Event ID 4625

Kein Zugriff auf eine lokale Webseite / Event ID 4625


Da ich bei der Einrichtung unsere MOSS2010 Server Plattform wieder einmal auf ein kleines Problem gestoßen bin, möchte ich dieses kurz beschreiben und auch die Lösung dazu zeigen. Vorab gesagt gibt es im Netzt viele Informationen darüber, aber da ich diesen Blog auch mit als kleine Doku verwende, werde ich dieses Problem noch einmal aufnehmen.

Problembeschreibung:
Bei dem Versuch eine erstellte Website im SharePoint, lokal auf dem Webfrontend Server aufzurufen erscheint jedes Mal das Anmeldefenster. Selbst nach mehrmaliger Eingabe der korrekten Benutzerinformationen wird der Zugriff verweigert. Zusätzlich wird im Eventlog die Fehlemeldung 4625 angezeigt.
Fehler4625_01
Event ID: 4625

Dieses Problem tritt vor allem auf, wenn die Webseite für die Windowsauthentifizierung und das NTLM Protokoll verwendet wird. Sollte die Webanwendung schon für das Kerberos-Protokoll eingerichtet sein gibt es keine Probleme.

Lösung:
Damit auch bei NTLM die Webseite Lokal vom Webfrontendserver aufgerufen werden kann, muss die Registry angepasst werden. Dafür gibt es 2 Methoden die im MS KB Artikel KB896861 beschrieben werden.

Methoden:
1. Deaktivieren des Loopback-Checks in der Registry. Dafür muss der folgende Schlüssel gesetzt werden:
Fehler4625_02

oder,
2. Angeben der Hostnamen
Fehler4625_03
Bei dieser Methode ist darauf zu achten das ein "Multi-String Value" Schlüssel erstellt wird. Wenn mehrere Websites vorhanden sind können die Name in diesen Schlüssel Zeile für Zeile eingetragen werden.

Ich hoffe es hilft euch.

Gruß, Mario

Kategorien:2010, SharePoint
  1. Tobia Teich
    17. Januar 2012 um 16:35

    Wir haben dieses Problem jetzt. Der Server ist ein Windows Server 2008 R2 mit SharePoint Server 2010 SP1. Im Registry-Baum unter LSA haben wir nur einen einen Unterschlüssel: Performance.
    Sind alle anderen Einstellungen dann Standardeinstellungen oder bezieht sich der Artikel auf eine andere Windows Version?

    Danke im Vorraus für eine Antwort.

    • 17. Januar 2012 um 20:12

      Hallo,
      ich habe den Registry-Pfad eben noch einmal auf verschiedenen Windows Servern (W2K3, W2K8 und W2K8 R2) aufgerufen und
      bin immer zu den gesuchten Schlüssel gekommen.
      Habt Ihr euch mal den MS KB Artikel angesehen? In diesem steht der genaue Pfad zu dem Schlüssel, er muss unter HKEY_LOCAL_MACHINE vorhanden sein.
      Hier noch mal der Link zum http://support.microsoft.com/kb/896861 !
      Ihr könnt ja auch mal das „Fix It“ Tool von der Seite verwenden, hat bei mir auch schon funktioniert.

      Kann es sein das Ihr vielleicht durch eine Domain-Policy nicht genügend Rechte habt die Registry zu durchsuchen?

      Bis denn Gruß
      Mario

  2. Tobia Teich
    18. Januar 2012 um 10:40

    Hallo Mario,
    danke für die schnelle Antwort. Jetzt haben wir alles noch einmal überprüft. Der Fehler lag bei uns😦, LSA liegt nochmal unter …Services. Irgendwann sieht man den Wald vor lauter Bäumen nicht mehr.

    Und nach Eintragen des Schlüssel funzt es jetzt. 1000Dank!!!

    Herzlichen Gruß an alle!
    Tobia

  1. No trackbacks yet.

Schreibe einen Kommentar

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s

%d Bloggern gefällt das: